5 thoughts on “The v1.9.0.0 OCTGN module for Mage Wars is released!

  1. I am having a problem when I attempt to validate my deck, it is giving me the error:

    Validation Failed: Akiro’s Hammer is not legal in an Anvil Throne Warlord Deck.

Leave a Reply

Your email address will not be published.